import re
regex = re.compile(r"(.*)text", flags=re.DOTALL | re.UNICODE)
test_str = "text abcd text text efgh"
subst = "${1}bar"
result = regex.sub(subst, test_str)
if result:
print(result)