using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)(?=(?:\d{3})+(?!\d|\.\d))";
string substitution = @",";
string input = @"123456789123456789123456789
123456789
12345678
12345678.11";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}