use strict;
my $str = '123456789123456789123456789
123456789
12345678
12345678.11';
my $regex = qr/(?<=\d)(?=(?:\d{3})+(?!\d|\.\d))/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";