const regex = /(?<=\d)(?=(?:\d{3})+(?!\d|\.\d))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)(?=(?:\\d{3})+(?!\\d|\\.\\d))', 'gm')
const str = `123456789123456789123456789
123456789
12345678
12345678.11`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);