re = /(?<=\d)(?=(?:\d{3})+(?!\d|\.\d))/m
str = '123456789123456789123456789
123456789
12345678
12345678.11'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result