using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?|ftp):\/\/[a-z0-9-]+(?:\.[a-z0-9-]+)+(\/[\w-]+)*\/[\w-.]+$";
string input = @"https://adozona.hu/afa/Afa_elsz.amolasa_ha_nem_fizeti_ki_a_vevo_a_s_0CFBE";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}