const regex = /^(https?|ftp):\/\/[a-z0-9-]+(?:\.[a-z0-9-]+)+(\/[\w-]+)*\/[\w-.]+$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?|ftp):\\\/\\\/[a-z0-9-]+(?:\\.[a-z0-9-]+)+(\\\/[\\w-]+)*\\\/[\\w-.]+$', 'g')
const str = `https://adozona.hu/afa/Afa_elsz.amolasa_ha_nem_fizeti_ki_a_vevo_a_s_0CFBE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}