re = /^(https?|ftp):\/\/[a-z0-9-]+(?:\.[a-z0-9-]+)+(\/[\w-]+)*\/[\w-.]+$/
str = 'https://adozona.hu/afa/Afa_elsz.amolasa_ha_nem_fizeti_ki_a_vevo_a_s_0CFBE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end