package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(https?|ftp):\/\/[a-z0-9-]+(?:\.[a-z0-9-]+)+(\/[\w-]+)*\/[\w-.]+$`)
var str = `https://adozona.hu/afa/Afa_elsz.amolasa_ha_nem_fizeti_ki_a_vevo_a_s_0CFBE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}