$re = '/^(https?|ftp):\/\/[a-z0-9-]+(?:\.[a-z0-9-]+)+(\/[\w-]+)*\/[\w-.]+$/';
$str = 'https://adozona.hu/afa/Afa_elsz.amolasa_ha_nem_fizeti_ki_a_vevo_a_s_0CFBE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);