import re
regex = re.compile(r"^(https?|ftp):\/\/[a-z0-9-]+(?:\.[a-z0-9-]+)+(\/[\w-]+)*\/[\w-.]+$")
test_str = "https://adozona.hu/afa/Afa_elsz.amolasa_ha_nem_fizeti_ki_a_vevo_a_s_0CFBE"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")