using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?:http(?:s)?(:\/\/)?)?(www\.)?discord\S*\]\(((?!discord)\S)*\)";
string input = @"--- positives
[https://discord.com/scam](https://other-website.com/scammy-link)
[https://discord.com/scam](https://other-website.com)
[http://discord.com/scam](http://other-website.com/scam)
[www.discord.com/scam](www.other-website.com/scam)
[discord.gg/invite](https://other-website.com/scam)
[discord](https://other-website.com/scam)
--- negatives
[https://discord.com/not-scam](https://discord.com/not-scam)
[discord.com](https://www.discord.com/tos)
[discord invite](https://discord.gg/qwerty)
[discord.com/not-link](not a link)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}