import re
regex = re.compile(r"\[(?:http(?:s)?(:\/\/)?)?(www\.)?discord\S*\]\(((?!discord)\S)*\)", flags=re.MULTILINE)
test_str = ("--- positives\n\n"
"[https://discord.com/scam](https://other-website.com/scammy-link)\n"
"[https://discord.com/scam](https://other-website.com)\n"
"[http://discord.com/scam](http://other-website.com/scam)\n"
"[www.discord.com/scam](www.other-website.com/scam)\n"
"[discord.gg/invite](https://other-website.com/scam)\n"
"[discord](https://other-website.com/scam)\n\n"
"--- negatives\n\n"
"[https://discord.com/not-scam](https://discord.com/not-scam)\n"
"[discord.com](https://www.discord.com/tos)\n"
"[discord invite](https://discord.gg/qwerty)\n"
"[discord.com/not-link](not a link)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")