import Foundation
let pattern = #"\[(?:http(?:s)?(:\/\/)?)?(www\.)?discord\S*\]\(((?!discord)\S)*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
--- positives
[https://discord.com/scam](https://other-website.com/scammy-link)
[https://discord.com/scam](https://other-website.com)
[http://discord.com/scam](http://other-website.com/scam)
[www.discord.com/scam](www.other-website.com/scam)
[discord.gg/invite](https://other-website.com/scam)
[discord](https://other-website.com/scam)
--- negatives
[https://discord.com/not-scam](https://discord.com/not-scam)
[discord.com](https://www.discord.com/tos)
[discord invite](https://discord.gg/qwerty)
[discord.com/not-link](not a link)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)