import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?:http(?:s)?(:\\/\\/)?)?(www\\.)?discord\\S*\\]\\(((?!discord)\\S)*\\)";
final String string = "--- positives\n\n"
+ "[https://discord.com/scam](https://other-website.com/scammy-link)\n"
+ "[https://discord.com/scam](https://other-website.com)\n"
+ "[http://discord.com/scam](http://other-website.com/scam)\n"
+ "[www.discord.com/scam](www.other-website.com/scam)\n"
+ "[discord.gg/invite](https://other-website.com/scam)\n"
+ "[discord](https://other-website.com/scam)\n\n"
+ "--- negatives\n\n"
+ "[https://discord.com/not-scam](https://discord.com/not-scam)\n"
+ "[discord.com](https://www.discord.com/tos)\n"
+ "[discord invite](https://discord.gg/qwerty)\n"
+ "[discord.com/not-link](not a link)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}