$re = '/\[(?:http(?:s)?(:\/\/)?)?(www\.)?discord\S*\]\(((?!discord)\S)*\)/m';
$str = '--- positives
[https://discord.com/scam](https://other-website.com/scammy-link)
[https://discord.com/scam](https://other-website.com)
[http://discord.com/scam](http://other-website.com/scam)
[www.discord.com/scam](www.other-website.com/scam)
[discord.gg/invite](https://other-website.com/scam)
[discord](https://other-website.com/scam)
--- negatives
[https://discord.com/not-scam](https://discord.com/not-scam)
[discord.com](https://www.discord.com/tos)
[discord invite](https://discord.gg/qwerty)
[discord.com/not-link](not a link)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);