use strict;
my $str = '--- positives
[https://discord.com/scam](https://other-website.com/scammy-link)
[https://discord.com/scam](https://other-website.com)
[http://discord.com/scam](http://other-website.com/scam)
[www.discord.com/scam](www.other-website.com/scam)
[discord.gg/invite](https://other-website.com/scam)
[discord](https://other-website.com/scam)
--- negatives
[https://discord.com/not-scam](https://discord.com/not-scam)
[discord.com](https://www.discord.com/tos)
[discord invite](https://discord.gg/qwerty)
[discord.com/not-link](not a link)';
my $regex = qr/\[(?:http(?:s)?(:\/\/)?)?(www\.)?discord\S*\]\(((?!discord)\S)*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}