#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[$€]{1}(?P<amount>[\d,\.]+(?>\.\d{2}){0,})\b"
Local $sString = "2 BED / 2 BATH for $120,000.00, what a deal!!!" & @CRLF & _
"$120,000.00" & @CRLF & _
"€40,000. bla bla" & @CRLF & _
"€40.000, bla bla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")