use strict;
my $str = '2 BED / 2 BATH for $120,000.00, what a deal!!!
$120,000.00
€40,000. bla bla
€40.000, bla bla';
my $regex = qr/[$€]{1}(?P<amount>[\d,\.]+(?>\.\d{2}){0,})\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}