using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[$€]{1}(?P<amount>[\d,\.]+(?>\.\d{2}){0,})\b";
string input = @"2 BED / 2 BATH for $120,000.00, what a deal!!!
$120,000.00
€40,000. bla bla
€40.000, bla bla";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}