const regex = /[$€]{1}(?P<amount>[\d,\.]+(?>\.\d{2}){0,})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[$€]{1}(?P<amount>[\\d,\\.]+(?>\\.\\d{2}){0,})\\b', 'gm')
const str = `2 BED / 2 BATH for \$120,000.00, what a deal!!!
\$120,000.00
€40,000. bla bla
€40.000, bla bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}