re = /[$€]{1}(?P<amount>[\d,\.]+(?>\.\d{2}){0,})\b/m
str = '2 BED / 2 BATH for $120,000.00, what a deal!!!
$120,000.00
€40,000. bla bla
€40.000, bla bla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end