using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^_]*_){4}([^_]+)";
string input = @"Bubble_ALLTIERS_30-65+_M_2%Payers100-500_AEO7D_29_1_EN";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}