$re = '/^(?:[^_]*_){4}([^_]+)/m';
$str = 'Bubble_ALLTIERS_30-65+_M_2%Payers100-500_AEO7D_29_1_EN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);