const regex = /^(?:[^_]*_){4}([^_]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^_]*_){4}([^_]+)', 'gm')
const str = `Bubble_ALLTIERS_30-65+_M_2%Payers100-500_AEO7D_29_1_EN`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}