package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^_]*_){4}([^_]+)`)
var str = `Bubble_ALLTIERS_30-65+_M_2%Payers100-500_AEO7D_29_1_EN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}