#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\d{4})-(\d{2})-(\d{2})\b"
Local $sString = "Some text 2018-08-28 11:56:48 .Some text 2017-10-30 07:39:21"
Local $sSubst = "$3.$2.$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)