const regex = /\b(\d{4})-(\d{2})-(\d{2})\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d{4})-(\\d{2})-(\\d{2})\\b', 'gm')
const str = `Some text 2018-08-28 11:56:48 .Some text 2017-10-30 07:39:21`;
const subst = `$3.$2.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);