import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d{4})-(\\d{2})-(\\d{2})\\b";
final String string = "Some text 2018-08-28 11:56:48 .Some text 2017-10-30 07:39:21";
final String subst = "$3.$2.$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}