// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(\d{4})-(\d{2})-(\d{2})\b").unwrap();
let string = "Some text 2018-08-28 11:56:48 .Some text 2017-10-30 07:39:21";
let substitution = "$3.$2.$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}