$re = '/\b(\d{4})-(\d{2})-(\d{2})\b/m';
$str = 'Some text 2018-08-28 11:56:48 .Some text 2017-10-30 07:39:21';
$subst = "$3.$2.$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;