use strict;
my $str = 'Some text 2018-08-28 11:56:48 .Some text 2017-10-30 07:39:21';
my $regex = qr/\b(\d{4})-(\d{2})-(\d{2})\b/mp;
my $subst = '$3.$2.$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";