# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\/]+$/xyz/gm;t' <<< "/test/data/{id}/moreData/{id}
/test/data/{id}/moreData/{objId}
/test/data/{id}/moreData/{anything else}"