package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^/]+$`)
var str = `/test/data/{id}/moreData/{id}
/test/data/{id}/moreData/{objId}
/test/data/{id}/moreData/{anything else}`
var substitution = "xyz"
fmt.Println(re.ReplaceAllString(str, substitution))
}