$re = '~[^/]+$~m';
$str = '/test/data/{id}/moreData/{id}
/test/data/{id}/moreData/{objId}
/test/data/{id}/moreData/{anything else}';
$subst = "xyz";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;