#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^/]+$"
Local $sString = "/test/data/{id}/moreData/{id}" & @CRLF & _
"/test/data/{id}/moreData/{objId}" & @CRLF & _
"/test/data/{id}/moreData/{anything else}"
Local $sSubst = "xyz"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)