re = /[^\/]+$/m
str = '/test/data/{id}/moreData/{id}
/test/data/{id}/moreData/{objId}
/test/data/{id}/moreData/{anything else}'
subst = 'xyz'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result