use strict;
my $str = '/test/data/{id}/moreData/{id}
/test/data/{id}/moreData/{objId}
/test/data/{id}/moreData/{anything else}';
my $regex = qr~[^/]+$~mp;
my $subst = 'xyz';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";