#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".+:(\S+).+"
Local $sString = "q:* > event_id:5156 > count" & @CRLF & _
"q:* > event_id:5158 > count" & @CRLF & _
"q:* > event_id:3006 > count" & @CRLF & _
"q:* > event_id:4656 > count" & @CRLF & _
"q:* > event_id:4663 > count" & @CRLF & _
"q:* > event_id:3008 > count" & @CRLF & _
"q:* > event_id:1016 > count" & @CRLF & _
"q:* > event_id:4688 > count" & @CRLF & _
"q:* > event_id:5154 > count"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")