use strict;
my $str = 'q:* > event_id:5156 > count
q:* > event_id:5158 > count
q:* > event_id:3006 > count
q:* > event_id:4656 > count
q:* > event_id:4663 > count
q:* > event_id:3008 > count
q:* > event_id:1016 > count
q:* > event_id:4688 > count
q:* > event_id:5154 > count';
my $regex = qr/.+:(\S+).+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}