import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+:(\\S+).+";
final String string = "q:* > event_id:5156 > count\n"
+ "q:* > event_id:5158 > count\n"
+ "q:* > event_id:3006 > count\n"
+ "q:* > event_id:4656 > count\n"
+ "q:* > event_id:4663 > count\n"
+ "q:* > event_id:3008 > count\n"
+ "q:* > event_id:1016 > count\n"
+ "q:* > event_id:4688 > count\n"
+ "q:* > event_id:5154 > count";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}