// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".+:(\S+).+").unwrap();
let string = "q:* > event_id:5156 > count
q:* > event_id:5158 > count
q:* > event_id:3006 > count
q:* > event_id:4656 > count
q:* > event_id:4663 > count
q:* > event_id:3008 > count
q:* > event_id:1016 > count
q:* > event_id:4688 > count
q:* > event_id:5154 > count";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}