package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.+:(\S+).+`)
var str = `q:* > event_id:5156 > count
q:* > event_id:5158 > count
q:* > event_id:3006 > count
q:* > event_id:4656 > count
q:* > event_id:4663 > count
q:* > event_id:3008 > count
q:* > event_id:1016 > count
q:* > event_id:4688 > count
q:* > event_id:5154 > count`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}