re = /.+:(\S+).+/
str = 'q:* > event_id:5156 > count
q:* > event_id:5158 > count
q:* > event_id:3006 > count
q:* > event_id:4656 > count
q:* > event_id:4663 > count
q:* > event_id:3008 > count
q:* > event_id:1016 > count
q:* > event_id:4688 > count
q:* > event_id:5154 > count'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end