# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-(?=\S*$)/ /gm;t' <<< "test1234 - 15-03-16 - this-is-a-test.mp4
test1234 - 15-03-16 - this is a test.mp4
test1234 - 12-02-18 - this-is-another-test.mp4
test1234 - 12-02-18 - this is another test.mp4"