import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-(?=\\S*$)";
final String string = "test1234 - 15-03-16 - this-is-a-test.mp4\n"
+ "test1234 - 15-03-16 - this is a test.mp4\n\n"
+ "test1234 - 12-02-18 - this-is-another-test.mp4\n"
+ "test1234 - 12-02-18 - this is another test.mp4";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}