#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-(?=\S*$)"
Local $sString = "test1234 - 15-03-16 - this-is-a-test.mp4" & @CRLF & _
"test1234 - 15-03-16 - this is a test.mp4" & @CRLF & _
"" & @CRLF & _
"test1234 - 12-02-18 - this-is-another-test.mp4" & @CRLF & _
"test1234 - 12-02-18 - this is another test.mp4"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)