use strict;
my $str = 'test1234 - 15-03-16 - this-is-a-test.mp4
test1234 - 15-03-16 - this is a test.mp4
test1234 - 12-02-18 - this-is-another-test.mp4
test1234 - 12-02-18 - this is another test.mp4';
my $regex = qr/-(?=\S*$)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";