using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-(?=\S*$)";
string substitution = @" ";
string input = @"test1234 - 15-03-16 - this-is-a-test.mp4
test1234 - 15-03-16 - this is a test.mp4
test1234 - 12-02-18 - this-is-another-test.mp4
test1234 - 12-02-18 - this is another test.mp4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}