re = /-(?=\S*$)/m
str = 'test1234 - 15-03-16 - this-is-a-test.mp4
test1234 - 15-03-16 - this is a test.mp4
test1234 - 12-02-18 - this-is-another-test.mp4
test1234 - 12-02-18 - this is another test.mp4'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result